zlib安装

在编译软件./configure 时得到错误反馈

checking zlib.h usability… no
checking zlib.h presence… no
checking for zlib.h… no

zlib软件包所包含的库经常被一些软件的压缩或解压缩函数用到,所以如果编译软件时需要Zlib则说明这个软件正好含有压缩或解压缩函数,我们需要安装zlib软件包。

先到zlib官方网站:http://www.zlib.net 上下载源码来安装zlib软件包。

目前最新版本zlib是zlib1.2.3,安装开始;

1
2
3
4
5
6
wget http://www.zlib.net/zlib-1.2.3.tar.gz
tar -xvzf zlib-1.2.3.tar.gz
cd zlib-1.2.3
./configure
make
sudo make install

这就完成了zlib1.2.3的安装,由于安装zlib1.2.3需要编译,所以最基本的编译器是要安装好的。